Posts tagged mercurial

There are 3 posts for the tag mercurial

Getting Mercurial 1.8.1 to work against a repository with a self-signed SSL certificate

For a project with some friends, we’ve set up our own private Mercurial repository. We’re publishing it using hgweb and apache, and since we want it encrypted, we use a self-signed certificate. This has been working fine until recently, when I upgraded Mercurial from 1.6.x to 1.8.1, because it turns out that in Mercurial 1.7.2, they started throwing a big fat error when you try to work against a repository with a self-signed certificate:C:\Users\Johan\HgReps\MsmqRestService>hg in abort: erro...

Posted by johan on March 28, 2011

Progress on the new blog engine

Hmmm, it seems that I did not manage to replace Subtext with my new blog engine, Alpha, before the end of 2010 as I optimistically thought when I started in October. It turns out that there are other things to do than to program when you’re on paternal leave (ya, rly!) I am, however, making progress with it. It basically displays the posts as I want it to, and the tagging and the tag cloud is working. What I really need to do in order to replace Subtext is to get Alpha to work with Windows Live ...

Posted by johan on January 02, 2011

I’m gonna build my own blog engine, because it’s never been done before, or maybe I can just do it better!

Today is the first day of my paternity leave, I’ll be home with my little daughter for at least six months. Which is great! But I immediately started to get the itch to write some code. I needed a hobby project. Since I suck at coming up with great ideas, I decided to be a good Jedi and build my own blog engine! Yes, I know, there really is no need for another blog engine. Except that there is. The one I would like to use doesn’t seem to be out there. Also, it seems like a perfect way to try ou...

Posted by johan on October 18, 2010